aUSD transfer through XCM from Astar to Acala

I’ve been encountering some issues with transfering aUSDs from Astar to Acala since the reopening this week.
I’m doing it from the portal, using my EVM address, sending to my substrate Acala address. The connection works fine, i’m able to see the funds on both addresses via the portal transfer window. I can send the fund as well after authorizing it but I never was able to retrieve the funds.
It always sends to this unknown address 0x0000000000000000000000000000000000005004. I’ve tried several times, always the same results. I can provide the transaction hashes if need be.
Now, i just don’t know what to do next to get my funds there, i’m pretty much lost.

Please provide the transactions hash. I will later check with the devs.

Ok, so, the transactions hashes are 0x85880dccda01a96467e135fac3e70bca5a4bcf427852758c39d866344a6d43ec, 0x0a37ca511d4635d4ae87e612d813cb768090524d17dc13b5539d78a7309dc78a, 0xfc43e9611e548fb2a8a0511ace4bfb0e8d0e954db22850478fa3d533d9b7d2c3 and 0x821b346570ee9e588ab4688bab4517a5d04dfc2b1fe8797ec7f9d4efa571f128

Thanks for your time

Hells there I have encountered almost the same problem, I was transferring from Acala to a Astar but the transaction failed on the astar end.
Extrinsic Hash:
XCM transfer hash:

We are currently looking in to this issue and will be fix very soon.
We will keep you updated here.


Ok so I got the funds from a friend because liquidation was nigh.
We may have pin pointed why it behaved like that. I had X ausd on my EVM address and 0.000 ausd on my native acala address. This might have been the issue. He sent me some ausd from his native acala address then he sent more from his evm address and everything worked well

Yesterday we send all aUSD that was stuck in the relay chain to the addresses.
The reason why this happened was that Acala enabled the transaction without notice, meaning that we didn’t open on our side, so the aUSD stayed in the relay chain. Those who transferred during this period now have their aUSD back.

If you transferred aUSD after we opened the HRMP channel, there was no issue.